Обновление 3.11

Материал из WiKi - UserSide
Перейти к: навигация, поиск

Дата обновления: июль 2017

Требуется версия: 3.10

Несколько слов от автора - особенности версии

  • В этой версии мы постарались добавить побольше интересных изменений. В т.ч. тех, о которых давно просили клиенты. Пересказывать нет смысла - лучше ознакомьтесь с полным списком изменений.
  • Мы блокируем работу старых модулей us_abills и us_utm5. Они давно были заменены на модули usm_abills и usm_utm5, но с ними ещё можно было работать
  • Все старые модули по взаимодействию с биллингами (us_nodeny, us_nodeny_plus, us_bgbilling, us_hydra, us_lanbilling, us_ipacct), которые работали напрямую с базой данных ERP "UserSide" были переписаны и теперь работают с ней по API (usm_nodeny, usm_nodeny_plus, usm_bgbilling, usm_hydra, usm_lanbilling, usm_ipacct). Рекомендуем переходить на них, хотя старые модули ещё можно будет использовать в версии 3.11.
  • У нас появилась группа в Telegram для взаимного общения клиентов и разработчиков между собой: https://t.me/usersideeu

Особенности в проведении обновления

  • Обновите MySQL до версии 5.7 (5.6 тоже пока годится, но лучше до 5.7) MariaDB до версии 10.1
  • Установите PostGIS [1]
  • После обновления - на странице "Настройка - Уведомления - E-mail" выполните правильную настройку почтовой службы. Расширился функционал.
  • После обновления - проверьте всё ли в порядке в разделах: "Блокнот", "Оборудование - Коммутаторы", "Оборудование - Радиооборудование", "Оборудование - Системные устройства", "Оборудование - Медиаконвертеры"

Список изменений: просмотреть

Проведение обновления: инструкция